Witamy na GTAOnline Obecny czas to 2017-03-24, 05:21 Użytkowników: 69019
Strona główna | Użytkownicy | Grupy | Faq | Regulamin | Zaloguj

GTAONLINE.PL
Tematy otagowane jako: ustawienia
1. Ustawienia kierunkowskazów
Hej ponownie, mam problem, otóż chcę, aby przy tych kierunkowskazach były włączone lampy, np. gdy włączamy prawy kierunkowskaz, prawa lampa miga, a lewa się świeci - i na odwrót. Próbowałem ustawiać w tych cyferkach.. Ale nie przynosiło to efektów, zazwyczaj psułem kod. Za pomoc oczywiście :piwo: oraz R* .

[lua]
leftkey = ","
rightkey = "."
bothkey = "/"

LightState1 = {0}
LightState2 = {0}

BlinkT = {}
BlinkS = {}

function Blinker(thePlayer,mode)
local vehicle = getPedOccupiedVehicle(thePlayer)
if vehicle then
if BlinkT[vehicle] then
killTimer(BlinkT[vehicle])
BlinkT[vehicle] = nil
setVehicleLightState(vehicle,0,LightState1[vehicle])
setVehicleLightState(vehicle,1,LightState2[vehicle])
setVehicleLightState(vehicle,3,0)
setVehicleLightState(vehicle,2,0)
setVehicleOverrideLights(vehicle,0)
else
setVehicleOverrideLights(vehicle,2)
setElementData(vehicle,"asd","asd")

local a,b = getVehicleLightState(vehicle,0),getVehicleLightState(vehicle,1)
LightState1[vehicle] = a
LightState2[vehicle] = b

if mode == leftkey then
setVehicleLightState ( vehicle, 1, 1 )
setVehicleLightState ( vehicle, 2, 1 )
if a == 0 then
BlinkT[vehicle] = setTimer(Blink,250,0,vehicle,1,0,3)
elseif a == 1 then
BlinkT[vehicle] = setTimer(Blink,250,0,vehicle,2,0,3)
end
elseif mode == rightkey then
setVehicleL...
2. Pobieranie ustawienia z mety
Witajcie nie dziala mi pobranie ustawienia z mety tutaj kody:

local blipid get("blipid")
local blipget("blip")
local start get("rozpoczecie")
local koniec get("oddanie")



local start createMarker(start,"cylinder",1.2,255,0,0,150)
local oddanie createMarker(koniec,"cylinder",4,255,0,0,150) --Marker wgrania mapy
local blip 
createBlip(blip,blipid


<meta
<
script src="praca_c.lua" type="client"/>
<
script src="praca_s.lua" type="server"/>

<
settings>
<
setting name="oddanie" value="1117.87,1293.78,09.82"/> 
<
setting name="blip" value="1117.87,1293.78,09.82"/> 
<
setting name="blipid" value="52"/> 
<
setting name="rozpoczecie" value="1103.45,1296.80,09.82"/> 
</
settings>
</
meta>


[ Dodano: 2016-07-20, 19:35 ]
Nie wiem dlaczego to nie działa

[ Dodano: 2016-07-20, 21:00 ]
Pomoze ktos ?
3. [GF] Ustawienia AntyCheata
Witam. Mam problem z AC. Zmienilem czas uruchamiania i gaszenia silnika w GM, i wszystko bylo by cacy gdyby nie ''Zostałeś zbanowany, powód: NOP SetVehicleEngine/AirBrk''. Ucze sie przerabiac mapki i jest to honest w wersji 1.1.7. Problem polega na tym ze gdy uruchomie silnik i podczas jazdy go wylacze zaczyna banowac z w/w informacja. Czy jest mozliwosc przestawienia AC tak aby nie gryzl sie z cmd /silnik, ewentualnie jezeli sie nie da tego dostroic to czy jest mozliwosc wylaczenia tej funkcji?
Wydaje mi sie ze to bedzie gdzies tu, aczkolwiek nie jestem pewien.
[code]
forward LicznikPojazd(); //Naprawiony przebieg
public LicznikPojazd()
{
foreach(Player,i)
{
if(GetPlayerState(i)==PLAYER_STATE_DRIVER)
{
VehID=GetPlayerVehicleID(i);
if(GetPlayerSpeed(i)>4&&GetPlayerSpeed(i)<10){ SamochodInfo[VehID][sPrzebieg]+=0.003; }
else if(GetPlayerSpeed(i)>10&&GetPlayerSpeed(i)<50){ SamochodInfo[VehID][sPrzebieg]+=0.006; }
else if(GetPlayerSpeed(i)>50&&GetPlayerSpeed(i)<100){ SamochodInfo[VehID][sPrzebieg]+=0.01; }
else if(GetPlayerSpeed(i)>100&&GetPlayerSpeed(i)<150){ SamochodInfo[VehID][sPrzebieg]+=0.02; }
else if(GetPlayerSpeed(i)>160&&GetPlayerSpeed(i)<200){ SamochodInfo[VehID][sPrzebieg]+=0.04; }
GetVehicleParamsEx(VehID,engine,lights,alarm,doors,bonnet,boot,objective);
if(engine)
{
if(SamochodInfo[VehID][sPaliwoTyp]==1) vPaliwoTxt="Pb";
else if(SamochodInfo[VehID][sPaliwoTyp]==2) vPal...




phpBB by Przemo modified by xXx 2003-2016

Template GTAONLINE created by gtaonline.pl



Strona wygenerowana w 0,08 sekundy. Zapytań do SQL: 8